AngularJS 1.5.3 在IE9 环境下失效

目前AngularJS 在IE9以下运行都有此问题


具体表现为如下几点



  • 绑定的ng-click事件无效,不能被触发。


  • 页面中编写的angularJS 表达式不能被解析



我做过的尝试



  • 在网上搜了一圈,大多数都是被告知如何解决IE7兼容的问题。比如引入json2.js文件.未果


  • 尝试过其他IE版本,在IE9以上、谷歌、火狐等浏览器均可正常运行


  • 对了,IE9浏览器下,只能执行run()方法里面的代码,貌似controller里不执行





目前我不清楚到底是不是浏览器兼容问题,还是angularJS在使用过程中由于没有按照特定注意事项去编写代码所导致的问题。


静候诸位援助
已邀请:

真搞不懂为毛微软会做出这么垃圾的浏览器,客户还要使用这么操蛋的东西。。。

要回复讨论请先登录注册